Problem with Amazon Web Services Preventing Revision Assistant from Loading
Incident Report for Revision Assistant
Resolved
Amazon has resolved the issues they were having with S3 and Revision Assistant is back in fully working order.
Posted Feb 28, 2017 - 18:41 EST
Monitoring
Current status: the Revision Assistant website does load, just verrrrrry sloooooowly. If you stick it out and let the site load (which might be a minute or two) you should be able to login and work without substantial issues. Some resources (like rubrics and assignment PDFs) will fail to load, but you can write and get signal checks.

For their part, Amazon has said they've identified the root cause and are continuing to work on stabilizing the system.
Posted Feb 28, 2017 - 14:55 EST
Investigating
Well, shoot. A few minutes ago, our team discovered that a problem with Amazon Web Services (AWS S3) is preventing our users from being about to log in to Revision Assistant. We use AWS S3 as a bulk repository for a variety of the documents and files that keep Revision Assistant running smoothly. We did figure out, however, that users who were already logged in when AWS S3 threw its tantrum would still be able to perform most tasks in Revision Assistant except for viewing our Rubrics and Assignment PDFs. Unfortunately, we do not have a quick fix for this sudden Amazon hissy fit and many other websites that use this service are also experiencing the same problems. When we figure out a solution you will be the first to know. (You can also follow their progress at https://status.aws.amazon.com/)

Until then, Amazon Web Services is in time-out.
Posted Feb 28, 2017 - 13:25 EST